您好,欢迎进入上海锐呈电气有限公司网站!
一键分享网站到:
您现在的位置:首页 >> 技术文章 >> NTP服务器调试与原理
NTP服务器调试与原理
浏览次数:7785发布日期:2010-09-09
目录
1   NTP概述                                            
1.1   NTP时间同步原理                                   
1.2   NTP分层构建原理                                   
2   M2000时间同步目的                                     
3   时间同步简介                                        
4   M2000系统时间同步方式                             
4.1   M2000-NTP设置类型                                  
4.2   M2000服务器Solaris系统的中间级NTP服务器设置     
4.2.1 查看服务器系统时间                                  
4.2.2 设置M2000管理控制台为中间级NTP服务器              
4.3   客户端NTP配置                                      
4.3.1 修改客户端注册表                                   
4.3.2 在CMD命令下修改                                   
5   网元设备时间同步方式                                
6   设置cisco3662为2级NTP                               
6.1   命令定义:                                         
6.2   配置实例                                            
 
 
 
 
 
 
 
 
NTP服务器调测总结
概述
介绍NTP(Network Time Protocol)和SNTP(Simple Network Time Protocol)的时间同步原理和分层构建原理。
 
NTP时间同步原理
NTP用于在分布式时间服务器和客户端之间进行时间同步,它定义了时间同步实现过程中所使用的结构、算法、实体和协议。NTP协议基于TCP/IP中的IP和UDP协议栈,也可以被其它协议组使用。从理论上讲,精度可达到十亿分之一秒。
NTP的时间同步基本原理如图1所示。
图1 NTP基本原理图
设备A和设备B通过网络相连,它们都有自己独立的系统时间,要实现各自系统时钟的自动同步,作如下假设:
在设备A和B的系统时间同步之前,设备A的时钟设定为10:00:00,设备B的时钟设定为11:00:00。
以设备B为NTP时间服务器,即设备A将使自己的时间与设备B的时间同步。
数据包在设备A和B之间单向传输所需要的时间为1秒。
设备A如果要从设备B同步时间,至少应知道两个信息,即:
A与B之间的时间差为多少,可称为offset。
A与B同步过程中,在路途上的损耗,可称为delay。
获得这两个消息,A即可顺利计算出如果要同步到B,应修改多少时间量。NTP协议约定的实际上是如何计算出A与B之间的Offset和Delay值。
系统时间同步的工作过程如下:
设备A发送一个NTP消息包给设备B,该消息包带有它离开设备A时的时间戳,该时间戳为10:00:00am(T1)。
当此NTP消息包到达设备B时,设备B加上自己的时间戳,该时间戳为11:00:01am(T2)。
当此NTP消息包离开设备B时,设备B再加上自己的时间戳,该时间戳为11:00:02am(T3)。
当设备A接收到该响应消息包时,加上一个新的时间戳,该时间戳为10:00:03am(T4)。
至此,设备A已经拥有足够的信息来计算两个重要的参数:
NTP消息来回一个周期的时延Delay=(T4-T1)-(T3-T2)。
设备A相对设备B的时间差offset=((T2-T1)+(T3-T4))/2。
这样设备A就能够根据这些信息来设定自己的时钟,使之与设备B的时间同步。
 
NTP分层构建原理
由设置时间同步机制的产生原因和目的可知,时钟源的个数越少时间统一性越好,但是由于网络的庞大和复杂,如果每个需要时间同步的机器都与同一台时间服务器相连是不现实的,因此在NTP模型中采用分层结构。
时间同步网络理论上根据其度和重要性一般分为从0-15的共16个级别或更多级,实际上不会大于6级。
第0级设备处于该子网络的特殊位置,是时间同步网络的基准时间参考源。它位于子网络的顶端,目前普遍采用卫星定位系统,即由GPS播发的UTC时间代码。
子网络中的设备可以扮演多重角色,例如一个第二层的设备,对于*层来说是客户机;对于第三层可能是服务器。
图2 NTP分层构建
图2所示,服务器在NTP分层构建中,可以配置为:
zui高层NTP服务器:指0级NTP服务器,向下一级(Stratum-1)提供时间同步服务。
中间层NTP服务器:指1级、2级等从上一级NTP服务器获取时间,为下一级提供时间同步服务。
NTP客户端:指从上一级NTP服务器获取时间,不提供时间同步服务。
一台主机可以从多个NTP Server上获得时间信息;一个NTP Server也可以向多个主机提供时间信息,同一级别的主机间可以相互提供时间信息。NTP协议zui多支持15级客户端。
说明:
NTP协议占用端口123,使用UDP(User Datagram Protocol)协议通信。因此必须保证各节点间IP链路畅通。
SNTP和NTP比较
SNTP是一个简化了的NTP服务器和NTP客户端策略。SNTP在时间同步实现上没有什么更改,只是在以下的控制功能上没有NTP强大。
时间同步的错误处理功能。
多服务器过滤功能。
多时间源选择(连接多个NTP服务器,并通过算法进行对比分析,获得zui的时间源)。
 M2000时间同步目的
时间同步是为了保证M2000和网元设备的时间一致。
移动网络组网方式复杂,网元众多。由于移动网络网元采用统一操作维护方式,要求各网元时间必须保持一致,这样才能确保M2000正确管理各网元上报的告警和性能数据,不至于产生混乱。
时间不准确造成的影响有:
在告警信息中,如果时间不准确,将无法判断告警发生的先后、距发现时的时间间隔、告警之间的关联等。在性能数据记录和统计过程中,如果时间不准确将直接影响统计的精度等。 为此需要提供一套非人工干预的方法,随时准确地调整各网元的操作维护时间。
时间同步简介
介绍时间同步的定义、时间同步方案的要素以及实施时间同步方案后对系统性能和其他操作维护特性的影响。
时间同步定义
时间同步又称时刻同步,是指时间的同步,要求信号的起始时刻与UTC(世界协调时)时间保持一致。
时间同步的操作就是按照接收到的时间来调整设备的时钟和时刻。
时间同步方案的要素
一般时间同步方案中至少包含两个要素,即时间同步的方法和时间参考源的选择。目前时间同步网络构建中,依照NTP(Network Time Protocol)协议和SNTP(Simple Network Time Protocol)协议进行时间同步是比较常见的方法。
时间参考源的选择主要是为时间同步网络中提供一个标准的时间参考源,确保整个网络的时间参考依据的准确性。比较常见的时间参考源包括GPS卫星等。
对系统性能的影响
当采用NTP协议描述的Client/Server模式实现时间同步时,NTP Client与NTP Server之间的消息帧为128个字节,因此基本不会影响网络传输性能。但当大量的NTP Client同时向NTP Server发起连接时,会对NTP服务器的CPU,内存等资源造成损耗,影响NTP server的性能。因此当采用NTP协议构建时间同步网络时,每个上级节点的NTP Server直接携带的下级NTP节点不能超过300个,否则可能影响性能。子节点的NTP Client时间同步请求的频度建议每30分钟一次或更长时间,并尽可能减少并发请求的几率。
对操作维护的影响
时间同步特性是移动网络操作维护领域的重要特性,其对其他特性的主要影响包括:时间同步特性可以确保移动网络中网管和网元的时间的准确性和一致,对于故障管理中的故障上报的及时性、故障信息的准确性和故障的关联性分析等方面都具有重要意义。否则,如果网元时间不准确或网元和网管时间不同步,可能会影响对故障问题的判断和处理。时间同步特性对于日志的记录、查询、显示和审计分析等特性的准确具有重要意义。否则,如果时间不准确或全网时间不一致,可能会造成日志记录不准确,并影响正常的日志审计功能。时间同步特性对于性能管理中的性能数据的记录,性能数据的收集和分析具有重要意义。否则如果时间不准确或全网时间不一致,可能导致网元性能数据记录和打点时间不准确,造成性能数据失效。时间同步特性对于呼叫跟踪和定位问题等业务具有重要的意义,否则如果时间不准确或全网时间不一致,可能造成无法正常进行呼叫跟踪业务。
 
 M2000系统时间同步方式
M2000-NTP设置类型
移动网络中的时间同步使用标准协议NTP/SNTP实现。华为2GM2000服务器采用Solaris操作系统(版本为Solaris8或Solaris10),支持基于NTPV3协议版本的NTP特性。通过对Solaris操作系统的文件/etc/inet/ntp.conf中特定参数的配置,在移动网络中,将M2000服务器配置为NTP Client,给M2000服务器应访问的NTP服务器的IP地址,M2000服务器即可从的NTP服务器获得时间同步消息。另外可以将M2000管理控制台设置为中间级时间服务器,而我们实际应用也是把M2000作为中间级NTP服务器,从上级NTP服务器获取时钟源,给下级网元提供时间同步参考源。
M2000服务器Solaris系统的中间级NTP服务器设置
查看服务器系统时间
#Date
如果时间不准确,先修改系统时间。
#date mmddHHMMYYYY.SS
mm代表月。
dd代表日。
HH代表小时。
MM代表分钟。
YYYY代表年。
SS代表秒。
例如时间设置为2005-11-17 16:30:43,执行以下命令:
# date 111716302005.43
Mon Nov 17 16:30:43 CST 2005
设置2G-M2000管理控制台为中间级NTP服务器
设置M2000管理控制台为中间级时间服务器,既同步上级服务器的时间,又作为下级服务器的时间源。
前提条件:
移动网络中的上一层NTP服务器已配置。
M2000管理控制台的时区、日期和时间正确。
以root用户登录管理控制台。
背景信息
一般情况下M2000服务器被配置为NTP客户端。在没有其他服务器可被配置为中间级时间服务器时,M2000系统的管理控制台Netra240,可被设置为中间级时间服务器。
操作步骤
打开“ntp.conf”。
# cp /etc/inet/ntp.server /etc/inet/ntp.conf
# TERM=vt100; export TERM
# vi /etc/inet/ntp.conf
在server 127.127.XType.0前增加server 上级NTP服务器的IP地址 prefer,上级NTP务器的IP地址。
说明: 如果有多个上层NTP服务器,就写多行,每行对应一个NTP服务器,如下:server   上级NTP服务器的IP地址   preferserver  
将server 127.127.XType.0和fudge 127.127.Xtype.0 stratum 0中的XType修改为1。
1表示本机时间为标准时间源。
删除fudge 127.127.1.0 stratum 0中的stratum 0。
在broadcast 224.0.1.1 ttl 4前加#注释掉该行,禁用广播模式。
保存“ntp.conf”并退出vi。
任务示例
例如,设置同步IP地址为192.168.75.250的服务器的时间,那么“ntp.conf”中的:server 127.127.XType.0
fudge 127.127.XType.0 stratum 0
broadcast 224.0.1.1 ttl 4
修改后为:
server   192.168.75.250 prefer
server 127.127.1.0
fudge 127.127.1.0
#broadcast 224.0.1.1 ttl 4
保存退出后重启NTP服务
#svcadm disable svc:/network/ntp:default
#svcadm enable svc:/network/ntp:default
检查NTP服务状态
#svcs svc:/network/ntp:default
查询时间源信息。
# ntpq –p
ntpq -p命令返回信息的remote字段是M2000服务器时间源的地址,并显示该时间源的状态。
检查时钟同步路径信息。
# ntptrace
ntptrace命令会从本机开始跟踪整个NTP同步链,一直跟踪到NTP的zui高层。如果想查看更详细的信息,请执行ntptrace -v。
任务示例
管理控制台为中间级时间服务器
root@ossconsole # ntpq -p
     remote           refid      st t when poll reach   delay   offset jitter
==============================================================================
 *10.161.94.212    .LCL.          1 u   165 512 377   0.406    61.294 0.111
 +LOCAL(0)         LOCAL(0)       3 1    29   64 377   0.000     0.000 0.000
 
root@ossconsole #
root@ossconsole # ntptrace
localhost: stratum 2, offset 0.000039, synch distance 0.07640
10.161.94.212: stratum 1, offset 0.060665, synch distance 0.01015, refid 'LCL'
root@ossconsole #
由ntpq -p的返回结果*10.161.94.212可以看出,该主机同步的NTP服务器的IP地址为10.161.94.212,st列的值为1表示10.161.94.212位于第1层,由前面的星号可知状态正常。
由ntptrace的返回结果可以看出,该主机位于第2层,上一层的主机IP为10.161.94.212,位于第1层。
设置3G-M2000的NTP服务
操作步骤
执行以下命令,进入“yast”。
# yast
在“YaST Control Center”中,通过“↑”、“↓”选择“Network Services”。在“YaST Control Center”中,通过“Tab”和“↑”、“↓”选择“NTP Configuration”,然后按“Enter”。 通过“Tab”和“↑”、“↓”,在“Automatically Start NTP Daemon”中,选择“During Boot”,按“Enter”确认信息。
说明: 当弹出“Warning”对话框时,通过“Tab”选择“Continue”后按“Enter”。此警告不影响NTP Client设置。通过“Tab”,在“NTP Server Configuration”下的“Address”中输入NTP Server IP地址。之后通过“Tab”选择“Test”测试NTP配置,具体详情请参见图1。 当系统提示Server is unreachable or does not respond properly. 时,说明配置不成功。当系统提示Server is reachable and responds properly. 时,说明配置成功。
图1 配置NTP客户端
操作步骤
执行以下命令,进入“yast”。
# yast
在“YaST Control Center”中,通过“↑”、“↓”选择“Network Services”。
在“YaST Control Center”中,通过“Tab”和“↑”、“↓”选择“NTP Configuration”,然后按“Enter”。
通过“Tab”和“↑”、“↓”,在“Automatically Start NTP Daemon”中,选择“During Boot”,按“Enter”确认信息。
说明:
当弹出“Warning”对话框时,通过“Tab”选择“Continue”后按“Enter”。此警告不影响NTP Client设置。
通过“Tab”,在“NTP Server Configuration”下的“Address”中输入NTP Server IP地址。之后通过“Tab”选择“Test”测试NTP配置,具体详情请参见图1
当系统提示Server is unreachable or does not respond properly. 时,说明配置不成功。
当系统提示Server is reachable and responds properly. 时,说明配置成功。
图1 配置NTP客户端
通过“Tab”选择“Finish”,完成NTP Client配置。
通过“Tab”选择“Quit”退出。
通过“Tab”选择“Finish”,完成NTP Client配置。
通过“Tab”选择“Quit”退出。
检查NTP服务状态
#ps -ef|grep ntp|grep -v grep
ntp      32038     1 0 21:34 ?        00:00:00 /usr/sbin/ntpd -p /var/lib/ntp/var/run/ntp/ntpd.pid -u ntp -i /var/lib/ntp
如果回显信息中有ntpd字样,说明M2000服务器上NTP服务正在运行。
如没有输出,则服务可能没起来,需重启进程。
#service ntp stop
#service ntp start
客户端NTP配置
M2000客户端为Windows2000 Professional或Windows XP操作系统,将操作系统设置为支持SNTP Client功能,M2000服务器的IP地址,M2000客户端从的M2000服务器获得时间同步消息。
有两种方式设置客户端
修改客户端注册表
打开注册表:在“开始”菜单→“运行”项下(或按Win+R)输入“Regedit”进入注册表编辑器。
修改默认时间服务器IP
展[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters]分支,双击NtpServer将键值修改为国家授时中心服务器的IP地址:210.72.145.44,然后点击“确定”按钮保存。
 
修改校时周期为一天:[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders \NtpClient]分支,并双击SpecialPollInterval键值,将对话框中的“基数栏”选择到“十进制”上,输入框中显示的数字正是自动对时的间隔(以秒为单位),比如默认的604800就是由7(天)×24(时)×60(分)×60(秒)计算来的。设定时间同步周期为一天,即24小时(86400秒),填入对话框,选十进制就填86400,选十六进制就填15180,点击确定保存关闭对话框。
添加时间服务器IP:[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers]在右边窗口点右键新建“字符串值”,将此“字符串值”命名为3。双击此新建的“字符串值”,输入IP:210.72.145.44,保存。将“默认”(即*个“字符串值”)修改为3即可。 为了方便,将下面横线之间的内容保存为reg文件,内容是一个注册表文件,功能有增加中国国家时间服务器IP,修改默认时间同步服务器IP,调整为一天校时一次。双击导入注册表文件即可。
在CMD命令下修改
选择“开始 > 运行”,输入cmd后按回车。在弹出窗口中执行以下命令:
c:\>net time /setsntp:M2000服务器的IP 地址
例如:c:\>net time /setsntp:192.168.75.30
查看的NTP服务器。
c:\>net time /querysntp
取消
执行net time /setsntp。
services.msc命令打开“服务”窗口。找到Windows Time服务,并重启该服务。
网元设备时间同步方式
对于有BAM的网元,网元的时间同步采用主从同步的组网方式,即主机的时间同步BAM、BAM 的时间同步M2000服务器。 对于没有BAM的网元,通常要求网元的OM模块单板可以支持NTP协议,可以从NTP Server获取时间。
 
这里以设备BSC-BAM为例进行说明。
 设置cisco3662为2级NTP
 命令定义:
命令的定义
——ntp access-group: 该全局命令用于路由器N T P服务的访问控制。
——ntp authenticate: 是一个全局命令,它启用N T P身份验证。
——ntp authentication-key: 该全局命令用于定义N T P身份验证的键值。
——ntp broadcast: 是一个接口命令,用于一特定接口来发送N T P广播包。
——ntp broadcast client: 是一个接口命令,使路由器通过特定接口来接收N T P广播包。
——ntp broadcast delay: 是一个全局命令,它用于设定数据包在路由器和N T P服务器之间一个回程所需时间的估计值。
——ntp clock-period: 这条全局命令不必输入,当使用N T P进行系统时钟同步时,路由器将自动产生这条命令。
——ntp disable: 这条接口命令使特定接口不接收N T P包。
——ntp master: 这条全局命令用来配置路由器为N T P主时钟,只有当没有可用的外部N T P源或者为测试用途才使用该命令。
——ntp peer: 该全局命令使路由器的系统时钟与其对等体的时钟同步(或对对等体的时钟进行同步)。
——ntp server: 该全局命令使路由器的系统时钟由时间服务器进行同步。
——ntp source: 该全局命令强制路由器在其N T P包中使用特定的源地址。
——ntp trusted-key: 该全局命令用于确认路由器的特定身份验证键值。
——ntp update-calendar: 该全局命令使N T P周期性地更新Cisco 7XXX 系列路由器的日历。
——show ntp status: 是一执行模式命令,用于显示路由器的N T P信息,它可以表明该路由器是通过N T P对等体进行时钟同步还是通过N T P服务器进行同步。
——show ntp association[detail]: 这条执行模式命令显示与N T P有关的信息,如轮询期等。
 配置实例
登录cisco3662并进入查询模式。
password:ntpserver
FS_WH_5F_NTPServer>en
FS_WH_5F_NTPServer>ntpserver
FS_WH_5F_NTPServer#
FS_WH_5F_NTPServer#clock set 10:11:22 10 june 2010
 
进入配置模式,配置路由器时间。
FS_WH_5F_NTPServer#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
 
设置路由器时区
FS_WH_5F_NTPServer#clock timezone beijing +8
 
设置端口FastEthernet0/0的ip地址,即M2000上级NTP服务器内网ip。也是NET远程控制IP。
FS_WH_5F_NTPServer(config)#interface FastEthernet0/0                      内网接口
FS_WH_5F_NTPServer(config-if)#ip address 192.168.75.250 255.255.255.0        接口ip
FS_WH_5F_NTPServer(config-if)#speed 100
FS_WH_5F_NTPServer(config-if)#full-duplex
 
设置端口FastEthernet0/1为公网IP地址,作为访问互联网上的一级NTP时钟源。
FS_WH_5F_NTPServer(config-if)#interface FastEthernet0/1                      外网接口
FS_WH_5F_NTPServer(config-if)#ip address 222.24.147.36 255.255.255.224         外网ip
FS_WH_5F_NTPServer(config-if)#duplex auto
FS_WH_5F_NTPServer(config-if)#speed auto
 
打开路由功能,设置路由器为rip协议,把内网ip和外网ip加入路由协议,从而实现路由功能。
FS_WH_5F_NTPServer(config-if)#ip routing                  打开路由功能
FS_WH_5F_NTPServer(config-if)#router rip                  使用rip协议
FS_WH_5F_NTPServer(config-if)#network 192.168.75.0   把内网ip加入路由
FS_WH_5F_NTPServer(config-if)#network 222.14.147.0         把外网ip加入路由
 
添加路由器网关,*个为访问公网的网关;第二个网关为访问内网3G网段的网关。
FS_WH_5F_NTPServer#ip route 0.0.0.0 0.0.0.0 222.14.147.33             外网网关
FS_WH_5F_NTPServer#ip route 192.168.1.0 255.255.255.0 192.168.75.5    内网网关
 
设置NTP服务器的上一级NTP地址,以获取NTP时钟源。同时给下级客户端提供标准的时钟源。
FS_WH_5F_NTPServer#ntp clock-period 17180240
FS_WH_5F_NTPServer#ntp server 133.100.9.2           时钟源1 来自日本GPS 主用
FS_WH_5F_NTPServer#ntp server 210.72.145.44         时钟源2 中国对时中心 备用
 
设置好后,检查NTP服务是否正常。如下指令,Clock is synchronized表示时间可以同步;stratum 2表示本NTP服务器在第二层;reference is 133.100.9.2表示参考的是上级ip为133.100.9.2的时钟源。
FS_WH_5F_NTPServer#show ntp status
Clock is synchronized, stratum 2, reference is 133.100.9.2
nominal freq is 250.0000 Hz, actual freq is 249.9944 Hz, precision is 2**24
reference time is CFBAD2CD.20B2D838 (10:56:13.127 beijing Thu Jun 10 2010)
clock offset is -0.1075 msec, root delay is 128.08 msec
root dispersion is 0.75 msec, peer dispersion is 0.38 msec
 
FS_WH_5F_NTPServer#show ntp associations
 
      address         ref clock     st when poll reach delay offset    disp
*~133.100.9.2      .GPS.             1     0   256 377   127.7    0.71     0.8
 ~210.72.145.44    0.0.0.0          16     - 1024    0     0.0    0.00 16000.
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured
FS_WH_5F_NTPServer#
 
 
 
   
    QQ在线客服
  •   在线咨询
  • 点击这里给我发消息
电话
86-021-51816731
手机
13918107979

沪公网安备 31011002000425号

扫一扫访问手机站扫一扫访问手机站
访问手机站